Kleiner Excel-Grundkurs für Einsteiger

  • Autor: ravenheart

    Kleiner Excel-Grundkurs für Einsteiger

    Excel gehört zur Gruppe der "Tabellenkalkulations-Programme". Es kann in erster Linie rechnen, und Listen verwalten.

    Grundlegendes

    Das Grundelement ist eine Zelle, dargestellt durch ein Kästchen. Die Zellen sind in Spalten und Zeilen als Tabelle (Matrix) angeordnet. Die Zeilen sind fortlaufend nummeriert, die Spalten mit Buchstaben gekennzeichnet. Mit diesen Koordinaten (Zellbezüge) lässt sich jede Zelle präzise beschreiben. Die erste Zelle liegt oben links und hat die Koordinaten A1. Darunter liegt A2, rechts neben A1 liegt B1.
    Eine Zelle kann (hauptsächlich) 3 verschiedene Inhalte haben: Eine Zahl, Text, oder eine Formel. Formeln beginnen immer mit =.

    Einfache Formelbezüge

    Angenommen, in Zelle A1 steht 3, und in Zelle B1 10. Trägst du nun z.B. in Zelle C1 die Formel =A1+B1 wird nach dem Drücken von Enter in dieser Zelle sofort 13, also das Ergebnis, angezeigt. Änderst du nun in Zelle A1 die 3 in eine 6, steht in C1 sofort 16. Excel kann so selbst große Tabellen fast in Echtzeit berechnen! Jede Änderung wird sofort umgesetzt, wenn die Eingabe durch Enter abgeschlossen wird!
    Man kann nun wiederum den Bezug einer Zelle, die eine Formel enthält in eine andere Formel einbauen, also mit dem Ergebnis weiter rechnen. Schreibe also noch in Zelle D1:
    = C1/2 (C1 geteilt durch 2),
    steht in Zelle D1: 8. Änderst du A1 wieder zu 3, steht in C1 wieder 13 und in D1 sofort 6,5. So weit ganz einfach, aber auch noch banal.
    Aber Excel kann noch viel mehr! Es gibt HUNDERTE von Befehlen und Operatoren, die in Formeln verwendet werden können. Einer der wichtigsten ist der WENN-Befehl. Das Tückische bei Befehlen: Sie haben eine klar vorgegebene Struktur, und funktionieren nur dann, wenn diese Struktur "sklavisch" eingehalten wird!

    Bezüge mit WENN und ODER

    Die Struktur des WENN-Befehls ist:
    =Wenn(Prüfung; Dann-Wert; Sonst-Wert)
    Dabei sind die Klammern ebenso wichtig, wie das Semikolon als Trennzeichen zwischen den einzelnen Werten.
    Wert kann dabei auch eine Formel sein. Angenommen, in Zelle D1 soll das Ergebnis nur angezeigt werden, wenn A1 genau 5 ist. Sonst soll Zelle D1 leer bleiben. Der Wert leer wird durch 2 Anführungsstriche beschrieben (""). Ausformuliert soll die neue Formel für D1 also lauten:
    Wenn A1 fünf ist, dann berechne (und zeige): C1 geteilt durch 2, sonst lass diese Zelle leer.
    Die zu prüfende Bedingung ist also A1 = 5?. Ist die Bedingung erfüllt, kommt der Dann-Wert zur Anwendung, also C1 / 2. Ist die Bedingung hingegen NICHT erfüllt, nimmt Excel den Sonst-Wert, also "" (leer).... Die Fomel lautet damit:
    =WENN(A1=5;C1/2;"").
    Dabei lassen sich auch Befehle und Operatoren kombinieren. Einer wäre z.B. ODER. Um beim vorherigen Beispiel zu bleiben: Ziel ist es jetzt, dass der Wert in D1 nicht nur bei A1 = 5, sondern auch bei A1 = 3 gezeigt wird. In allen anderen Fällen soll D1 weiterhin leer bleiben.
    Der ODER-Befehl ist eher ein Operator, seine Struktur ist:
    ODER (Bedingung1; Bedingung2; ....). Im hiesigen Fall:
    ODER(A1=5;A1=3)
    Eingesetzt in die o.a. WENN-Formel wird dies als Prüfbedingung. Sie lautet dann:
    =WENN(ODER(A1=5;A1=3);C1/2;"").
    Es wurde nur die Prüfbedingung A1=5 durch ODER(A1=5;A1=3) ersetzt, der Rest ist gleich geblieben! Ausformuliert heißt die Formel nun:
    Wenn A1 = 5 oder A1 = 3, dann rechne (und zeige) C1 / 2, sonst zeige "" (leer).
    Die bisherigen Beispiele bezogen sich auf einen Ausgangswert, nämlich den in A1. Man kann aber die Bedingung ebenso an das Ergebnis stellen, das funktioniert genau so: War A1 3, war oben das Ergebnis in D1 6,5. War A1 6, war D1 8. Excel soll nun D1 nur anzeigen, wenn es kleiner als 6 ist. Dafür benutzt du die Größer/Kleiner-Zeichen der Tastatur. <6 heißt kleiner als 6 (6 steht auf der größeren Seite!).
    Die Berechnung, die in D1 (eventuell) durchgeführt wird, war ja C1 / 2. Um die Anzeige des Ergebnisses vom Ergebnis selber abhängig zu machen, musst du diese Berechnung in die Prüfung einbeziehen:
    =WENN(C1/2<6;C1/2;"")
    Übersetzt: Wenn die Berechnung C1 / 2 einen Wert <6 ergibt, dann rechne (und zeige) C1 / 2, sonst zeige "" (leer).
    An diesem Beispiel lassen sich nun sehr schön 2 Dinge zeigen, die belegen, dass Excel immer streng LOGISCH vorgeht! Angenommen, A1 sei 2! Dann wäre C1 also 12 (das war ja A1 + B1, B1 ist 10). Und C1 / 2 ist 6. D1 bliebe also leer, denn unsere Bedingung lautete ja kleiner 6. Und 6 ist nun mal nicht kleiner 6, sondern ist genau 6!
    Oder A1 sei -30 (minus 30). C1 (A1 + B1) wäre dann -20 (-30 + 10). C1 / 2 ist damit -10. Das würde angezeigt, denn 10 ist zwar größer als 6, aber minus 10 ist nun mal kleiner als 6!

    Die Ausgabe verbessern

    Als Letztes gibt es noch eine Übung mit Text. Beim obigen Beispiel war es so, dass D1 leer blieb, wenn A1 zu groß war, also 2 oder größer. Um den Benutzer der Tabelle nun darauf hinzuweisen, warum D1 dann nicht das Ergebnis zeigt, kann man anstelle D1 nur leer zu lassen, auch einen Hinweis ausgeben! A1 ist zu groß soll dieser lauten.
    Damit Excel Text von Zellbezügen unterscheiden kann, muss Text in Formeln immer in "" gesetzt werden. ("Leer", also "", ist eigentlich nichts anderes als leerer Text). Setzt man stattdessen nun zwischen die "" einen Text, wird der ausgegeben! Die Formel sieht dann so aus:
    =WENN(C1/2<6;C1/2;"A1 ist zu groß")
    Übersetzt: Wenn die Berechnung C1 / 2 einen Wert < 6 ergibt, dann rechne (und zeige) C1 / 2, sonst zeige "A1 ist zu groß".
    Ergebnis: Bei allen A1-Werten unter 2 wird in D1 das Rechenergebnis angezeigt. Ist das Rechenergebnis aber 6 oder größer, erscheint dort der Text A1 ist zu groß.

    Weitere Hilfen




    • Wenn du mehr als 2 Zellen summieren willst, z.B. A1 bis A5, kannst du das so schreiben: =A1+A2+A3+A4+A5. Komfortabler ist dann aber der Befehl SUMME, vor allem, weil dort der gesamte Bereich angegeben werden kann:



    • =SUMME(A1:A5).
      [i]Übersetzt: [I]Addiere alle Zellen von A1 bis A5. Der Doppelpunkt heißt also bis. Das fördert die Übersichtlichkeit und spart Tipparbeit.
    • Hast du angefangen, eine Formel zu schreiben, also so bald das = eingegeben ist, kannst du die Zelle(n), die du eintragen möchtest, auch einfach mit der Maus anklicken! Excel fügt dann sofort den Zellbezug, also die Zell-Koordinaten, in die Formel ein. Und das klappt auch mit mehreren Zellen. Markierst du (durch ziehen mit gedrückter Maustaste) mehrere Zellen, fügt Excel diese automatisch als „Bereich“, mit Doppelpunkt ein.

    Das bis hier gezeigte ermöglicht dir das Erstellen einfacher Tabellen mit häufigen Befehlen. Weitere Formeln oder Problemstellungen kannst du im Forum erfragen, oder mit der Excel-Hilfe nachschlagen. Auch hier gilt, Übung macht den Meister.

    Artikel als pdf:[Blockierte Grafik: http://www.paules-pc-infothek.de/ppf2/images/smiles/pdf.gif]

Jetzt mitmachen!

Sie haben noch kein Benutzerkonto auf unserer Seite? Registrieren Sie sich kostenlos und nehmen Sie an unserer Community teil!