W7 Updates

  • Die Updatepolitik von MS wird mir immer unsympathischer. Beim derzeitigen Patchday dauert das Finden der Wup's auf W7 Rechnern bis zu zwei Stunden, auf einem meiner Rechner läuft die Suche jetzt seit drei Stunden, ohne Ergebnis.


    Unter W8.1 und W10 ist die Update-Suche eine Sache von Sekunden.


    Ganz offensichtlich soll einem die Verwendung von W7 vermiest werden, wo es nur geht.

  • NAchdem ich den Thread hier gefunden/gelesen habe, hab ich es bei mir (Win7 Ultimate x64) direkt mal getestet.
    Mein Windows ist so eingestellt, das es mir Updates sucht und mir Bescheid gibt, also manuelle Installation...


    Es wurden mir direkt Updates angezeigt, welche sich dann auch, bis auf zwei anstandslos installieren ließen.
    Nach dem Neustart des PCs, bin ich aufgrund der zwei fehlerhaften Installationen direkt wieder auf Updates suchen gegangen.
    Und was soll ich sagen...ich muss die Aussage, das es dauert, leider bestätigen...er sucht und sucht und sucht und sucht und sucht....just in the Moment, seit 40 Minuten....

  • Eben kommt ein Anruf von einem Freund: Mein PC rödelt seit 2 Stunden nach dem Update. Au Backe, schon wieder "Arbeit" und Ärger!

    Internetter Gruß
    Günther ...Oldie But Even Goldie....
    Komm an den Bodensee und fühle Dich unter netten Leuten wohl!

  • Eben kommt ein Anruf von einem Freund: Mein PC rödelt seit 2 Stunden nach dem Update. Au Backe, schon wieder "Arbeit" und Ärger!

    Dann hoffen wir, dass es nichts ernstes ist!!

  • NAchdem ich den Thread hier gefunden/gelesen habe

    Und ich diesen: Es wird nach Updates gesucht, und gesucht, weiter gesucht, immer noch am suchen, sucht Windows 7


    Es wurden mir direkt Updates angezeigt,

    Das Benachrichtigungs-Symbol erscheint bei mir seit 2 Monaten leider nicht mehr, muss das Fenster vom Windows-Update immer manuel öffnen und nachsehen.



    Dann hoffen wir, dass es nichts ernstes ist!!

    Sicherlich nicht, es ist die blöde und lahmarschige Update-Suche, das haben wir im obigen alten Thread vom November ja schon festgestellt.



    auf einem meiner Rechner läuft die Suche jetzt seit drei Stunden, ohne Ergebnis.

    Na dann : Prost Mahlzeit!
    P.S. Bei mir hat die Update-Suche gerade begonnen, zu sehen an der svchost.exe im Taskmanager und CPU: [Blockierte Grafik: http://www2.pic-upload.de/img/29078818/Unbenannt.jpg]

  • Edit:
    nach 1 Stunde Update-Sucher erschien (oh Wunder) das Benachrichtungs-Symbol und vermeldete dass neue Updates bereitstehen ( 10 wichtige-3 optionale).


    Das Herunterladen scheint auch (wieder) Ewigkeiten zu dauern, rödelt bereits ca. 1/2 Stunde , Fortschritt Null!
    [Blockierte Grafik: http://www2.pic-upload.de/img/29079444/Unbenannt.jpg]


    Edit: Jetzt fast 1 Stunde vergangen, immer noch kein Fortschritt! :evil::thumbdown:

    2 Mal editiert, zuletzt von Oldviking ()

  • Und ich diesen: Es wird nach Updates gesucht, und gesucht, weiter gesucht, immer noch am suchen, sucht Windows 7


    Das Benachrichtigungs-Symbol erscheint bei mir seit 2 Monaten leider nicht mehr, muss das Fenster vom Windows-Update immer manuel öffnen und nachsehen

    In den anderen Thread habe ich aktuell noch nicht rein geschaut. Sollte ich das vielleicht? Gibt es da neue/andere Erkenntnisse? :8O:


    Mit dem "Es wurden mir direkt Updates angezeigt" meinte ich genau das was Du in Deiner Antwort geschrieben hast. Bei mir erscheint das Benachrichtigungs-Symbol auch immer seltener bis gar nicht mehr.
    Auch finde ich es witzig, wenn ich dann die Updates zum installieren bestätige, steht da nimmer die übliche Meldung "Updates werden gesucht/geladen" oder was da immer stand. Bei mir steht dann jetzt immer "Windows 10 wird installiert".
    Wenn das Updates ziehen dann fertig ist, und Windows in die Installations-Phase übergeht, dann sieht alles wieder wie gewohnt aus.


    Ich glaube langsam, ich muss mein Win7 mal neu und frisch installieren. Irgendwie ist seit/trotz Deinstallation der "gwx.exe" irgendwas von der Win10-Seuche in meinem guten Win7 hängen geblieben

  • Irgendwie ist seit/trotz Deinstallation der "gwx.exe" irgendwas von der Win10-Seuche in meinem guten Win7 hängen geblieben

    Sehe ich auch so, deswegen:


    Bei mir steht dann jetzt immer "Windows 10 wird installiert".

    Das steht bei mir nie.
    Zum Glück! :0engel:


    In den anderen Thread habe ich aktuell noch nicht rein geschaut. Sollte ich das vielleicht? Gibt es da neue/andere Erkenntnisse?

    Eigentlich nicht...


    Edit: nach 1 Stunde beginnt das Herunterladen der Updates ( Fortschritt: 17 %), sowas nenne ich .. :thumbdown:

    Einmal editiert, zuletzt von Oldviking ()

  • Au Backe, schon wieder "Arbeit" und Ärger!

    Ich habe dem Freund geraten, das Update zu unterbrechen, neu zu starten und dann den PC herunter fahren. Vorläufig hat er Ruhe und kann vielleicht morgen das Ganze wiederholen.

    Internetter Gruß
    Günther ...Oldie But Even Goldie....
    Komm an den Bodensee und fühle Dich unter netten Leuten wohl!

  • Abhilfe schafft schon manchmal ein Neustart des PC, wenn wieder mal ein Update einen Neustart braucht, dieser aber nicht angezeigt wird und die weitere Installation der anderen Updates damit blockiert.

  • Abhilfe schafft schon manchmal....

    Bei mir lief alles eigentlich wie immer, problemlos aber seeeeehr langsam.
    Alle 10 wichtigen Updates wurden installiert, jetzt wartet der Neustart.
    Dauer seit Updatsuche bis Neustart- Aufforderung: ca. 4 Stunden!


    Mir tun alle Arbeitnehmer leid die diesen "Kram" nach Feierabend noch vor sich haben!

  • Hier mal lesen: Windows 7 Updates werden nur mit maximal 25% CPU Leistung installiert

    Zitat von AHT
    • In der ersten Phase der Updatesuche holt sich der Dienst scheinbar Infos von der Festplatte. Die Prozessauslastung des für die Updatesuche zuständigen SVCHOST-Prozesses liegt eher im unteren Bereich. Der Speicherverbrauch des Prozesses steigt schnell an, fällt zwischendurch aber immer wieder etwas ab. Teilweise liegt er unter Vista im Bereich von 1GB! Es werden da scheinbar Daten über die installierten Updates gesammelt und im Speicher abgelegt. Diese Phase dauert in der Regel etwa 10 Minuten. Der Dienst scheint sich da bim Speicher eine Datenbank anzulegen.
    • Irgendwann verändert sich der Speicherverbrauch des Dienstes kaum noch. Die Prozessorauslastung liegt dann bei 100% (Singlecore Prozessor), der Speicherverbrauch bei mir etwa bei etwas unter 700MB. Die Prozessor- und RAM-Auslastung deuten darauf hin, dass im Speicher nachgeprüft wird, welche Update auf dem Gerät noch nötig sind. Tritt das Problem auf, dauerte bei mir diese Phase 7Stunden. Tritt es nicht auf, ist die Phase in unter einer Minute vorbei. Der Dienst baut in dieser Phase keine Internetverbindung auf!

    Das Problem scheint also nicht beim Server von Microsoft zu liegen, sondern beim Updatedienst. Er braucht unterschiedlich lange um festzustellen, welche Updates er noch braucht. Das kann eigentlich nur der Fall sein, wenn zwischendurch Infos auf dem Rechner abgelegt werden, die die weitere Suche erleichtern. Fehlen diese Infos oder sind die beschädigt, muss der Rechner erst mal lange herumrechnen, um die wieder zu erstellen.
    Das könnte unter anderem passieren, wenn bei den Updates eine bestimmte Reihenfolge nicht eingehalten wird - man die Servicepack zum Beispiel vor einer ersten Updatesuche installiert. Es könnte natürlich auch passieren, wenn eijn Datenfehler in einer dieser "Infodatenbanken" existiert, die die Updatesuche erleichtern sollte. Sucht der Rechner so lange, scheint er also im Prinzip beim Fixen eines Fehlers zu sein und man sollte ihn suchen lassen - das kann bis zu 8 Stunden dauern.

  • Also gestern Abend gleich kurz nach 19 Uhr 2-3 Minuten. Wie immer hier also

    Kann mich nur wiederholen, weil man das nicht verallgemeinern sollte, wenn der eine
    oder andere ein Problem hat - Millionen anderer haben keins.


    Suche 2-3 Minuten, Herunterladen und installieren von 7 Patches gute
    30 Minuten, Neustart und ein paar Minuten warten bis er wieder bereit
    war: Alles zusammen gezählt ~40 Minuten. Das ist jetzt 10 Minuten
    länger als es sonst "normalerweise" braucht, aber absolut kein Thema.
    Und, wie bereits an anderer Stelle berichtet, war das seit Jahr und Tag
    noch niemals anders sondern für mein Empfinden stets zügig und flott! :top:


    Obwohl ich "zu den Bösen" gehöre die samt und sonders alle Win 10
    Leimrutenpatches seit April gnadenlos ausgeblendet haben, deshalb brauche
    ich beispielsweise auch kein Anti-Win-10-Tool, das nun schon wieder von
    Winzigweichs Agenten ausgehebelt wird...

  • Also, heimgekommen, PC gestartet, kurz ins Internet und nach ca. 3-4 Minuten unten rechts die Benachrichtigung, dass es neue Updates hat.
    Draufgeklickt, Fenster ging auf, auf "Installieren" gedrückt, 2 Minuten gewartet und da kam die Meldung vom Neustart.


    Neustart zugelassen und knappe 2 Minuten später war alles ok und mein PC lief.


    Auslastung war nicht spürbar!
    Das ganze dauerte keine 10 Minuten.


    So muss es sein!


    Edit:
    Dem PC ein Wienachtsguetzli (Keks) hinhalten. :D

  • AHT schrieb:

    Zitat

    Das könnte unter anderem passieren, wenn bei den Updates eine bestimmte Reihenfolge nicht eingehalten wird - man die Servicepack zum Beispiel vor einer ersten Updatesuche installiert. Es könnte natürlich auch passieren, wenn eijn Datenfehler in einer dieser "Infodatenbanken" existiert, die die Updatesuche erleichtern sollte. Sucht der Rechner so lange, scheint er also im Prinzip beim Fixen eines Fehlers zu sein


    Könnte und scheint.....
    Mag alles sein, jedoch habe ich 3 Windows 7- Systeme und auf allen dauert der Update-Kram so lange wie vorhin beim PC.
    Insofern schließe ich mal Datenfehler oder andere Probleme aus.
    Wäre mir dann doch ein Zufall zu viel.



    Und, wie bereits an anderer Stelle berichtet, war das seit Jahr und Tag
    noch niemals anders sondern für mein Empfinden stets zügig und flott!


    Zumal diese langen Update- Zeiten vor 1 oder 2 Jahren bei mir auch noch nicht waren.
    Und nu ?


    Das ganze dauerte keine 10 Minuten.

    Windows 7 ?
    Davon hätte ich gerne mal einen Screenshot (die Zeiten).

    Einmal editiert, zuletzt von Oldviking ()

  • Also, heimgekommen, PC gestartet, kurz ins Internet und nach ca. 3-4 Minuten unten rechts die Benachrichtigung, dass es neue Updates hat.
    Draufgeklickt, Fenster ging auf, auf "Installieren" gedrückt, 2 Minuten gewartet und da kam die Meldung vom Neustart.


    Das ist das Normalverhaten. Versäume mal versuchsweise zwei Patchdays - dann könnte es sein, dass deine Probleme anfangen. Das ist erst mal nur ein Verdacht von mir.

Jetzt mitmachen!

Sie haben noch kein Benutzerkonto auf unserer Seite? Registrieren Sie sich kostenlos und nehmen Sie an unserer Community teil!