Fehler in Hilfe und Problem mit Schleifen in Callbacks

    Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    Unsere Datenschutzerklärung wurde aktualisiert. Mit der Nutzung unseres Forums akzeptierst Du unsere Datenschutzerklärung. Du bestätigst zudem, dass Du mindestens 16 Jahre alt bist.

    • Fehler in Hilfe und Problem mit Schleifen in Callbacks

      Ich bin immer noch mit meinem FTP-Programm beschäftigt. Da sind mir 2 Dinge aufgefallen:
      1. Wenn ich in einer Funktion, die als Callback dient, eine Schleife erzeuge (in meinem Fall WhileLoop), diese Funktion mittels SetTimerA-API innerhalb einer anderen Schleife aufgerufen wird kann es passieren, dass &Loop plötzlich den Wert der anderen Schleife hat. In meinem Fall war &Loop der großen Schleife 28633, im Callback wird aber immer nur von 0 bis 2 gezählt. Ich habe das Problem mittels einer For-Schleife und lokaler Variable gelöst, der Test läuft noch. Dabei fiel mir auf (ich habe noch nie For benutzt), dass
      2. ein grober Fehler in der Hilfe ist. Unter Abschnitt 9.4 werden For-Schleifen angesprochen, die aber in den Beispielen alle mit EndWhile abgeschlossen werden. Richtig wäre EndFor, wie im Hilfeeintrag von For.
      XProfan-Semiprofi (XProfan X4a+XPIA+LemonEd)
      Ryzen 1700X/MSI B350 PC MATE/16GB RAM@2933MHz/Radeon HD7770 OC/Creative X-Fi XTreme Music/90TB HDD+256GB Samsung 960 EVO/28" Samsung 4k
      XBox Classic/360S/One S/One X Scorpio Edition/PS3 Super Slim 500GB/PS4 Pro (XBL-ID: jacdelad, PSN: jacdelad84) auf 60" 4k/3D LG
      OnePlus 7 8GB/256GB
      jacdelad.bplaced.net