WMV ruckelt nicht, aber MP4 ruckelt

  • Hallo,


    ich habe einen Film in mp4 aufgenommen und mit einem Video Editor einen dunklen Abschnitt aufgehellt, da im Programm keine mp4 Voreinstellungen zum Speichern vorhanden waren, die zu der Aufnahme passten, habe ich es im Format wmv gespeichert, das hat zwar 5 Stunden gedauert, aber das Ergebnis entspricht meinen Erwartungen. Nun habe ich alle Dateien in mp4 und möchte auch dabei bleiben. Also habe ich ein anderes Tool genommen, um die Datei in mp4 zu konvertieren. Das hat auch soweit alles geklappt, nur der Abschnitt, wo ich die Helligkeit und der Kontrast verändert wurden, ruckelt bei mp4.

    Woran könnte das liegen? Die wmv wird fehlerfrei abgespielt.


    Programme

    Videobearbeitung: AVS4you Video Editor

    Konvertierung: Aiseesoft Video Converter Ultimate


    Anmerkung

    Mit Aiseesoft Video Converter Ultimate kann ich das Video auch bearbeiten, aber mit demselben Ergebnis, es hat auch in diesem Abschnitt geruckelt.

    Die Einstellungen scheine ich richtig gemacht zu haben, Tonspur usw. stimmt alles und wie gesagt, wmv ist perfekt. Warum verhält sich mp4 in diesem Abschnitt so, selbst wenn die Veränderung von einem anderen Programm vorgenommen wurde? Das heißt, ich habe es zunächst mit Aiseesoft in mp4 versucht und nun mit AVS4you, über den Umweg eines anderen Format. Trotzedem macht Aiseesoft den gleichen Fehler.

    Mit freundlichen Grüßen
    Michi

  • Ich habe es nun mit den Converter von AVS4you versucht, hat auch wieder einige Stunden gedauert. Das Ergebnis ist zwar besser, aber hat auch Fehler. Verstehe das nicht. Woran liegt das?

    Mit freundlichen Grüßen
    Michi

  • Abifiz

    Hat den Titel des Themas von „wmv ruckelt nicht, mp4 ruckelt“ zu „WMV ruckelt nicht, aber MP4 ruckelt“ geändert.
  • Hallo, Michi!


    Wenn der AVS4you Video Editor keine Speicherung im mp4-Format anbietet, dann fehlt möglicherweise ein dafür nötiger Codec oder eine andere wichtige Datei.

    Der fehlende Codec muss dann wohl noch aus dem Internet nachgeladen und ins Programm-Verzeichnis integriert werden.


    Wenn das Rendern bzw. das Konvertieren so lange dauert, ist vermutlich die Prozessorleistung zu schwach.


    Auch ausreichend Arbeitspeicher sollte im PC vorhanden sein (mindestens 8GB).


    Mit welchem Programm hast du die Videodateien aufgenommen?

  • Ich kann damit mp4 abspeichern, nur sind das Voreinstellungen, ich konnte die Einstellungen nicht finden, um selbst ein Profil zu erstellen, sodass die Auflösung und die Framerate (fps) im Ergebnis nicht passen. Nehme ich eines der fertigen Profile, dann stimmt also die Tonspur nicht mehr, weil die mit einer Framerate i.d.R. von 30 eingestellt sind, während ich 60 verwende.

    Meine CPU ist zwar schon etwas älter, aber es ist eine i7 und es sind 16 GB Arbeitsspeicher vorhanden.

    Aufgenommen wurde mit dem Aiseesoft Screen Recorder.


    Das Video hat drei Abschnitte, Teil 1 wurde nur vom Anfang etwas abgeschnitten, Teil 2 wurde die Helligkeit und der Kontrast verändert und Teil 3 wurde nur vom Ende etwas abgeschnitten. Das bedeutet, das nur Teil 2 das Problem mit mp4 hat, Teil 1 und Teil 3 haben den nicht. Es muss also an der Helligkeit und am Kontrast liegen, vielleicht gibt es mit der Framerate ein Problem. Das merkwürdig, ich sitze jetzt 3 Tage an dem Problem und habe es zunächst mit dem Aiseesoft Video Converter Ultimate versucht, aber das Ergebnis war mit dem von AVS4you, beim konvertieren in mp4, vergleichbar. Nur in WMW ist das Video von AVS4you fehlerfrei.

    Ich könnte es jetzt noch über Adobe Premiere Elements 2019 versuchen, aber das dauert auch wieder Stunden und ich kenne mich mit dem Programm nicht aus.


    Nachtrag

    Ich bin ... naja, ich konnte die Einstellung für das Profil in AVS4you jetzt finden, vermutlich dauert es wieder 5 Stunden und das Ergebnis ist absehbar, aber ich werde es dennoch versuchen.

    Was mir noch aufgefallen ist, Aiseesoft Video Converter Ultimate bietet die Möglichkeit Informationen über das Video anzuzeigen, dort wird der fps mit 100 angezeigt, obwohl die Aufnahmen mit 60 vorgenommen wurde, ich kann bei avs aber nur bis 60 speichern, mehr geht in Aiseesoft Video Converter Ultimate auch nicht. Obwohl also in jedem Programm nur 60 möglich sind, wird mir 100 angezeigt, ist vielleicht ein Programmfehler.

    Mit freundlichen Grüßen
    Michi

    3 Mal editiert, zuletzt von Michi () aus folgendem Grund: Ein Beitrag von Michi mit diesem Beitrag zusammengefügt.

  • Die von dir genannte CPU und Arbeitspeicher-Kapazität empfinde ich als gut geeignet.


    Für dein Projekt noch ein drittes installiertes Programm in die Videobearbeitung einzubinden, halte ich für kontraproduktiv.


    Ich vermute:

    1. Der AVS4you Video Editor ist noch nicht richtig konfiguriert.

    2. Der AVS4you Video Editor ist eine Freeware-Version und es fehlt darin eine Option, Videodateien, die unterschiedliche (oder solch hohe) Frameraten enthalten, zu verarbeiten.

  • Das ist keine Freeware.

    https://www.avs4you.com/de/register.aspx


    Zitat

    Arbeiten Sie mit allen wichtigen Formaten und HD-Videos.

    • Bearbeiten und speichern Sie Videos in allen gängigen Formaten (MP4, DVD, AVI, MOV, VOB, WMV, MKV, WEBM usw.).
    • Verarbeiten Sie Videos in jeder Auflösung: HD, Full HD, 2K Quad HD, 4K Ultra HD und DCI 4K.
    • Öffnen, bearbeiten und speichern Sie Videos in beliebten Formaten wie H.264, H.265 (nur Lesen), MPEG-4, usw.
    • Beschleunigen Sie die HD-Videobearbeitung dank integrierter Video-Cache-Technologie.
    • Verwenden Sie neue, automatische Voreinstellungen für leistungsstarke Computer.

    Mit freundlichen Grüßen
    Michi

    2 Mal editiert, zuletzt von Michi ()

  • Hallo Michi,


    das ist ein Laufzeitfehler der "MS Visual C++ Laufzeitumgebung"... Unter welchem Windows denn?


    Wie behebt man den Runtime Error R6025 in Windows? - als Info .... bitte jedoch nicht "Reimage" installieren....

    Erst wenn in Deutschland und der EU alle Chemikalien verboten sind; auch Kochsalz und Essig Abgabebestimmungen unterliegen und der letzte Hobbychemiker das Handtuch geworfen hat; wird die Politik sehen, dass es immer noch Terrorismus und Drogen gibt.

  • Windows 10 Pro 64 Bit


    Visual C++ Runtime Error! (Lösung (sversuch))


    Top 1

    Ich habe jetzt Visual Studio 2015, 2017 und 2019 und zwar beide Bit Versionen installiert. Laut Tutorial soll man das so machen.

    Aktuelle unterstützte Downloads für Visual C++


    Allerdings weiß nicht, wie ich das zu verstehen habe:

    Zitat

    Dies unterscheidet sich von allen früheren Visual C++-Versionen, da sie jeweils ihre eigenen Runtime-Dateien hatten, die nicht mit anderen Versionen geteilt wurden.

    Wäre es sinnvoll auch eine ältere Version zu installieren?


    Top 2

    Außerdem habe ich framework 3.5 neu initialisiert.

    Eine Anleitung

    1. In der Desktop Suche Control eingeben und auf Systemsteuerung (sieht etwas anders aus, ist die erweitere Variante) klicken,
    2. auf Programme und Features klicken,
    3. auf Windows Features aktivieren oder deaktivieren klicken,
    4. bei NET Framework 3.5 die drei Haken entfernen und das Windows neu starten,
    5. anschließend den Vorgang wiederholen und die drei Haken wieder setzen. Sollte Windows nach einer online oder offline Quelle fragen, auf die online Variante klicken,
    6. PC neu starten.

    Hinweis in eigener Sache

    Ich hatte vergessen, das ich die drei Haken bei NET Framework 3.5 schon einmal rausgenommen hatte und nicht wieder gesetzt habe. Vielleicht war das schon das Problem, ich muss das aber noch testen.


    Top 3

    Außerdem soll man den PC auf Fehler prüfen, das hatte ich aber schon vor einigen Tagen gemacht.

    1. In der Desktop Suche CMDl eingeben,
    2. auf Eingabeaufforderung einen Rechtsklick machen und als Administrator ausführen anklicken,
    3. gebe sfc /scannow und drücke die Enter Taste.

    Windows überprüft sich jetzt, das kann etwas dauern, bei Bedarf werden Fehler automatisch korrigiert.


    Sollte ich noch etwas nicht aufgeführt haben, bin ich über weitere Tipps sehr dankbar. Es wird einige Zeit dauern, bis ich weiß, ob die Maßnahmen erfolgreich waren.


    Nach dem ich den Runtime Fehler weggeklickt habe, ist eine zweite Fehlermeldung aufgetreten. Wie erhöht man Leerlaufthreads?


    Eines jagd das andere, kaum habe ich diese Fehlermeldung weggeklickt, erscheint folgendes Fenster. Ich habe den Wert jetzt auf 11 gestellt, mehr geht nicht.

  • Stell ich die Leerlaufthreads auf 11 braucht das Programm 9 Stunden. Somit ist die Einstellung jetzt auf 2, dann sind es "nur" 3 Stunden. Ob sich der Einsatz gelohnt hat, wird sich also erst noch zeigen.


    P.S. Für mich ist der Thread eine To-do-Liste, daher ist alles so Schrittweise dokumentiert.

    Mit freundlichen Grüßen
    Michi

  • Das Problem ist immer noch da, aber ich versteh da etwas nicht. Der erste Abschnitt ist ca. 70% groß, da ich nun nicht 2 Stunden warten möchte, bis der zweite Abschnitt anfängt, habe ich den ersten Abschnitt gekürzt und nun läuft der zweite Abschnitt ohne Fehlermeldung durch. Die länge des ersten Abschnitts scheint also das Problem zu sein. Was mach ich denn jetzt?

    Ich habe mir die Abschnitte jetzt noch einmal angesehen und das Programm scheint sie mit 30 fps importiert zu haben, obwohl es ja eigentlich eine 60 fps Aufnahme ist. Nun habe ich den langen Vorgang noch einmal gestartet, nur diesmal als mp4 mit 30 fps. Vielleicht bekomm ich Kontakt zum Support, denn irgendwie versteh ich das nicht. Schließlich macht er die 60 fps, wenn der erste Abschnitt kürzer ist. Vorteil 30 fps dauert nur halb solang, ich kann nur hoffen, das es die Tonspur nicht zerreist.

    Mit freundlichen Grüßen
    Michi

    2 Mal editiert, zuletzt von Michi ()

  • Vielleicht gibt es beim AVS4you Video Editor ein Limit bzgl. der Datenmenge bzw. der Größe der Videodatei, die bearbeitet werden soll?!

  • Auf 30 fps läuft es jetzt durch, ich weiß nur noch nicht, wie das Ergebnis ist, da es noch nicht fertig ist. Ich versteht das allerdings nicht, da die Aufnahme auf 60 fps eingestellt war, da ich auch auf verlustfrei eingestellt hatte, kann es natürlich sein, das Aiseesoft Screen Recorder dann auf 30 fps zurückgestellt wird.


    Es ist zum kotzen, jetzt kann der WMP die Daten nicht abspielen.

    ------------------

    Nach einem Neustart geht der WMP wieder und das Video sieht ganz gut aus, bis jetzt ist mir nur ein kleiner Ruckler aufgefallen. Der zweite Abschnitt läuft auch und die Tonspur ist synchron. Es scheint also tatsächlich an der Framerate gelegen zu haben. Warum auch immer die sich verstellt hat. Vielleicht kann mein PC die gar nicht erstellen, schließlich habe ich nur eine Nvidia 560 Grafikkarte. Die Programme können das natürlich, nur wandeln die dann eine 30 fps in eine 60 fps, obwohl ich davon ausgehe, das die Quelle eine 60 fps ist und schon ruckelt es. Ich vermute aber, das es an der Einstellung "verlustfrei" liegt, weil 30 fps die Standardeinstellung für solche Aufnahmen ist.

    Mit freundlichen Grüßen
    Michi

    4 Mal editiert, zuletzt von Michi () aus folgendem Grund: Ein Beitrag von Michi mit diesem Beitrag zusammengefügt.

  • schließlich habe ich nur eine Nvidia 560 Grafikkarte

    Zuspät eingestiegen in diesen Bereich!

    An der G-Karte sollte das nicht liegen. Das Rendern von Videos erfolgt unabhängig von dieser. Die Ausgabe der WMV könnte dann Probleme mit der G-Karte haben, wenn die Formate nicht passen.


    H.264, H.265 (nur Lesen) ? Da liegt schon das Problem! Zum exportieren von Material in diesen Formaten, muss zumeist erst eine Lizenz der Codex erworben oder Registriert werden. Zumindest kenne ich das nicht anders. Kostenpflichtige Lösungen habend dies zwar meist mit im Petto, doch auch da kann noch eine Extra-Anmeldung von Nöten sein.

    Dann gibt es auch noch Unterschiede im Videoformat! PAL/NTSC; 24/25/50/60FPS. H.264, H.265 haben auch noch ein paar Eigenheiten.

  • Ich habe jetzt das Cuda Toolkit von Nvidia installiert und den AVS Editor in den Einstellungen dafür freigegeben. Die Bearbeitungszeit hat sich um ca. 1 Stunde verkürzt. Ob es auch andere Auswirkungen hat, weiß ich noch nicht. Cuda hat sich auch in einem Visual Bereich installiert (musste bei der Installation extra bestätigt werden), vielleicht löst das einige Probleme, die ich mit dem Aiseesoft Screen Recorder immer noch habe.

    Wenn bei der Download Auswahl ein Feld mit 10 aufgeführt wird, dann steht das für Windows 10. Bei der Installation wird die Hardware geprüft, viel falsch kann man also nicht machen (hoff ich).

    Mit freundlichen Grüßen
    Michi

  • Vielleicht hilft Dir ja, was in den beiden Links (oder zumindest in einem davon) hier unten steht:


    Bandwidth Test fails using Cuda 9.1 and Visual Studio 2013
    Dear all, I have just started using GPU. I have two GPUs on my workstation, NVS 310 and Tesla K40c. I have Windows 7 OS and use Visual Studio 2013. I…
    forums.developer.nvidia.com


    https://www.ibm.com/support/pages/nvidia-cuda-toolkit-bandwidth-test-fails-under-microsoft-windows-server-2008-r2-ibm-idataplex-dx360-m3-server-6391

    Meine smarte, die kommenden Zeitalter bescheiden vorwegnehmende Signatur befindet sich noch in ihrem Herstellungsprozeß. Im 1. Quartal 2034 dürfte mit ihrer Lieferung zu rechnen sein.

    Vorläufig zitiere ich Karl Kraus: „Wer jetzt übertreibt, kann leicht in den Verdacht kommen, die Wahrheit zu sagen.“

    Dazu meint Pepino: Cogito, ergo schnurr'.


Jetzt mitmachen!

Sie haben noch kein Benutzerkonto auf unserer Seite? Registrieren Sie sich kostenlos und nehmen Sie an unserer Community teil!