Schlechtes Bild bei neueren AMD-Grafiktreibern

  • Hallo allerseits,

    seit Jahren habe ich ein Problem mit AMD-Grafiktreibern. Schon unter Win7 und seit Installation auch unter Win10 gibt es Folgendes:

    Wenn ich einen Treiber neuer als Version 21.19.519.2 von 2017 (angezeigt unter Gerätemanager-Eigenschaften-Treiber-Treiberversion) installiere, wird das Bild auf dem Monitor sehr schlecht dargestellt, das heisst es ist sehr körnig und mit viel zu starken Kontrasten (aber nicht verzerrt). Dies betrifft jeden neueren Grafiktreiber seit der genannten Version, alle Treiber älter als die genannte Version funktionieren dagegen einwandfrei. Der PC ist zum Monitor mit einem HDMI-Kabel angeschlossen. Ein Wechsel des HDMI-Kabels sowie die Herumstellerei an den Treibereinstellungen sowie der Einstellungen am Bildschirm brachte keine Besserung. Was könnte das Problem sein?

  • alle Treiber älter als die genannte Version funktionieren dagegen einwandfrei.

    Was spricht dagegen, diese älteren Treiber weiterzunutzen? Da Du auch Windows 7 erwähnst, gehe ich mal von einem älteren Rechner aus. Ältere und alte Grafik-Chips fliegen irgendwann mal aus der Unterstützung durch neue Treiber-Software raus.

    Erst wenn in Deutschland und der EU alle Chemikalien verboten sind; auch Kochsalz und Essig Abgabebestimmungen unterliegen und der letzte Hobbychemiker das Handtuch geworfen hat; wird die Politik sehen, dass es immer noch Terrorismus und Drogen gibt.

  • Was spricht dagegen, diese älteren Treiber weiterzunutzen?

    Das hier: KLICK


    Da Du auch Windows 7 erwähnst, gehe ich mal von einem älteren Rechner aus. Ältere und alte Grafik-Chips fliegen irgendwann mal aus der Unterstützung durch neue Treiber-Software raus.

    Da die jetzigen, aktuellen Treiber auch für die Grafikkarte, die in diesem Rechner verbaut ist aufgeführt werden, würde ich schon ganz gern updaten, auch weil Bugfixes und bessere Unterstützung für Anwendungen integriert worden sind.

  • Das verstehe ich natürlich. Um welchen Grafik-Chip bzw. Grafikkarte geht es genau?

    Erst wenn in Deutschland und der EU alle Chemikalien verboten sind; auch Kochsalz und Essig Abgabebestimmungen unterliegen und der letzte Hobbychemiker das Handtuch geworfen hat; wird die Politik sehen, dass es immer noch Terrorismus und Drogen gibt.

  • Der PC ist zum Monitor mit einem HDMI-Kabel angeschlossen. Ein Wechsel des HDMI-Kabels sowie die Herumstellerei an den Treibereinstellungen sowie der Einstellungen am Bildschirm brachte keine Besserung. Was könnte das Problem sein?

    Da Du schon einiges probiert hast, fällt mir nichts mehr ein. Vielleicht hat jemand anders noch Ideen?

    Erst wenn in Deutschland und der EU alle Chemikalien verboten sind; auch Kochsalz und Essig Abgabebestimmungen unterliegen und der letzte Hobbychemiker das Handtuch geworfen hat; wird die Politik sehen, dass es immer noch Terrorismus und Drogen gibt.

  • JochenPankow


    Meine Idee wäre:

    Testweise eine separate Grafikkarte jüngeren Baujahrs in den freien "PCIe x16"-Grafikkarte-Slot einsetzen und mit aktuellem Treiber ausprobieren.

  • Vielleicht würde eine Nachfrage im AMD-Forum etwas Brauchbare dazu bringen? :|


    (https://community.amd.com/t5/s…-forums/ct-p/supprtforums)


    Falls ja, würd' ich mich über eine Rückmeldung hier sehr freuen! :)

    Meine smarte, die kommenden Zeitalter bescheiden vorwegnehmende Signatur befindet sich noch in ihrem Herstellungsprozeß. Im 1. Quartal 2034 dürfte mit ihrer Lieferung zu rechnen sein.

    Vorläufig zitiere ich Karl Kraus: „Wer jetzt übertreibt, kann leicht in den Verdacht kommen, die Wahrheit zu sagen.“

    Dazu meint Pepino: Cogito, ergo schnurr'.


  • Testweise eine separate Grafikkarte jüngeren Baujahrs in den freien "PCIe x16"-Grafikkarte-Slot einsetzen und mit aktuellem Treiber ausprobieren.

    Leider z.Z. keine andere zur Hand.

    Ich habe schon einiges über ähnliche Dinge gelesen, allerdings konnte man so einen Fehler oft durch andere Treibereinstellungen umgehen. Hier halt dummerweise nicht. Sollte ich eine Lösung finden (die ich schon seit längerer Zeit suche), werde ich es hier mitteilen, sollte hier jemand noch Tipps haben (ohne Hardwareänderungen), nur her damit.

  • Habe etwas Neues, das vielleicht jemanden bekannt vorkommt und eine Lösung anbietet: Wenn ich im BIOS unter Northbridge-Konfiguration die Option "Onboard-HDMI-HD-Audio" einschalte, ist das Bild mit jedem Grafiktreiber schlecht, also auch mit denen, die ein gutes Bild liefern, wenn diese Option ausgeschaltet ist. Ansonsten gilt weiterhin das im 1. Post dieses Threads hinterlegte. Hat jemand eine Ahnung, woran das liegen könnte?

  • Da die jetzigen, aktuellen Treiber auch für die Grafikkarte, die in diesem Rechner verbaut ist aufgeführt werden, würde ich schon ganz gern updaten, auch weil Bugfixes und bessere Unterstützung für Anwendungen integriert worden sind.

    Verständlich.

    Allerdings: Bist du sicher, dass für deine Grafikkarte der AMD-Referenztreiber passend ist?

    Nur weil der darauf verbaute Grafikchip aufgeführt wird (AMD nennt keine Grafikkarten, sondern nur die GPUs!), heisst das noch lange nicht, dass deine Karte auch mit dem AMD-Treiber korrekt funktioniert.

    Ich habe nicht mitgezählt, wie viele Karten von Herstellern wie Asus, Zotac, Gigabyte etc. mir bisher in die Hände gekommen sind, die mit den Referenztreibern nur schlecht oder gar nicht liefen, sondern vom Kartenhersteller angepasste Treiber benötigen.


    Die Möglichkeit, dass der AMD-Treiber also nicht funktioniert, ist folglich vorhanden. Und wenn der Kartenhersteller für das verwendete Modell einen eigenen Treiber bereitstellt > Teste diesen! Dabei ist es irrelevant, ob bei AMD neuere Treiber verfügbar sind. AMD liefert nur ein Bauteil der Karte und muss nicht wissen, wie das Drumherum aussieht. Verweisen die Kartenhersteller bei ihren Karten explizit auf die AMD-Treiber, müsste man an anderer Stelle nach einem möglichen Fehler suchen. Wie du selbst festgestellt hast, gibt es bei deinem Rechner einen Zusammenhang zwischen den BIOS-Einstellungen für die Audio-Funktionen und der Grafikdarstellung. Vielleicht wird das durch ein neueres BIOS (sofern vorhanden) bereits behoben.

  • Danke für die Tipps aber leider ändern sie nichts. Die Grafik ist, wie oben bereits geschrieben, eine integrierte Radeon R7 in der AMD-A8-CPU. Somit kommen die Treiber direkt von AMD/Ati und werden für dieses Modell explizit aufgeführt.. Und auch das Bios ist auf dem letzten Stand. Erstaunlich ist, dass eine Audio-Funktion via HDMI offensichtlich Einfluß auf die Bilddarstellung haben kann.

  • amd.com --> Treiber und Support --> "Processors with graphics" auswählen --> "AMD A-Series Processors" auswählen --> "A8 Series APU for Desktops" --> deinen Prozessor aussuchen, auf "Absenden" klicken. System aussuchen, Treiber deinstallieren, neuen Treiber installieren, neustarten, fertig.

    Deine Beschreibung klingt wie das sogenannten "overscan", also zu hohe Bildwiederholfrequenz, könnte ich mir erklären, wenn du in der Tat den falschen Treiber nutzt. Deine Beschreibung des Treiberpakets klingt in der Tat danach...


    PS:

    Stell danach Auflösung und Bildwiederholfrequenz ein. Das könnte in der Tat der Knackpunkt sein. Eventuell ist dein Monitor nur ein sogenannter "Standard-Bildschirm"

Jetzt mitmachen!

Sie haben noch kein Benutzerkonto auf unserer Seite? Registrieren Sie sich kostenlos und nehmen Sie an unserer Community teil!