Suse 7.3 als Gateway

  • Hallo NG,


    seit einiger Zeit versuche ich einen Linux-Rechner als Gateway zu betreiben.
    Soweit klappt (fast) alles.
    Der Rechner kann sich per DSL ins Netz einwählen, nur die Sache mit den Clients klappt nicht.


    Kann mir jemand den grundsätzlichen Ablauf einer solchen Konfiguration beschreiben?
    Was könnte ich falsch gemacht haben??


    Die Kiste hat 2 Netzwerkkarten:


    eth0: 192.168.1.1 --> per DSL ins Net
    eth1: 192.168.5.99 --> ins interne Netz
    Client: 192.168.5.1 --> Windows Client (XP pro)


    Danke


    Tom

  • Hi!


    Hm also ich habe bis jetzt mehrere Webserver gemacht und einen Proxy installiert. EInen Gateway... könnte ich mir vorstellen wie es geht...


    Hast du das mit den IP's unter YAST schon richtig eingestellt?
    Ihc hab bei der SuSe Support datenbank auch einen Link gefunden, schau mal rein:
    http://sdb.suse.de/de/sdb/html/hoe_adsl_router.html


    Hoffe dir helfen zu können!!!
    LG, Katja

  • Danke Katja,


    die Einwahl unter Linux klappt wunderbar, das einzige was nicht klappt ist dass ich mit meinem MS-Client nicht über den Gateway ins Netz komme. obwohl die Anfragen bei Ihm ankommen und weitergeleitet werden.
    Das Routing müßte auch passen.


    T

  • Hi Tom!


    Da kann ich nu ehrlich nur raten.
    Ich schätze mal, wenn der Proxy es annimmt und weiterleitet, dann klappt es ja prächtig, aber gibt er die Pakete auch zurück? Das als erste frage.
    Mach mal vom MS-Client ein tracert [ip proxy] auf den proxy und wenn das klappt (was es ja sicher tut) ein tracert auf irgendeine seite.
    ja ich weiß jetzt sagst du mir, du kommst nicht ins netz, versuchs von einer anderen verbindung ;) davon gehe ich aus.
    Was ich mir aber auch denken kann ist das Problem wie bei Routern mit den inoffiziellen 192.168.x.x IP's. Was denkst du?
    Gruß, Katja

Jetzt mitmachen!

Sie haben noch kein Benutzerkonto auf unserer Seite? Registrieren Sie sich kostenlos und nehmen Sie an unserer Community teil!