Bootmanager bei Mandrake

  • Ich habe Linux Mandrake 7.0 , win 98 und win XP auf meinem PC!
    Wenn ich den PC jetzt starte bringt er mir zuerst den Linux Bootmanger, auf dem ich Linux , failsave, floppy und windows auswählen kann!
    Nachdem ich windows wähle, komme ich in den win XP Bootmangager, bei dem ich dann zwischen win XP und win 98 wählen kann.
    Ich möchte aber eigentlich alle meine Betriebssyteme in einem Bootmanager auswählen können.


    Kann ich nicht im Linux Bootmanager einstellen, dass er mehrere Windows-Betriebsysteme starten kann??



    oder: kann ich nicht im windows einstellen, dass er Linux auch bootet?
    Dazu müsste ich halt wissen, wie ich den Linux-BM loswerde!!


    Danke im voraus...


    MfG cYcaFleXx

  • Hi!
    Sag mal eben welche Dateisysteme (FAT32, reiserfs, jfs, xfs, NTFS) du bei allen dreien verwendet hast :)
    Gruß, Kes

  • Hallo Kes


    Meine Windowspartitionen sind alle FAT 32


    Meine Linux Partitionen sind...naja...weiß ich nicht. :? Da steht nur native und sweep aber ich habe nichts spezielles ausgewählt.


    MfG cYca :wink:

  • Also ich denke mir mal, dass du unter /etc/lilo.conf die lilo so umschreiben kannst, dass er beide Windows Versionen bootet. Dazu musst du allerdeings wissen, auf welchen hd's linux die erkennt.
    Du wirst in der lilo se´hen, dass irgendwo zb
    other = /dev/hdc
    label = windows
    steht.
    wenn du weißt, unter welchem device dein 98 und dein xp liegen, kannst du es dem entsprechend umschreiben.
    klingt kompliziert, ist aber ganz einfach.
    Du loggst dich als root ein und schreibst fdisk -l
    so siehst du das device und das filesystem. ich schätze, dass du unter linux sicher kein fat hast! also sind die beiden einzigsten FAT's deine beiden Windows Partitionen. Du merkst dir die device nummer und dann trägst du die in die lilo ein.
    da wo dein other = ........
    steht (s.o.) da änderst du je nachdem label = windows in windows98 oder XP um.
    Dann musst du darunter nochmal other = ... (andere windows partition)
    und label = windows[xx]
    so müsste es eigentlich klappen!!!
    ansonsten schmeisst du lilo halt raus und nimmst den XP Bootmanager (der hat doch sicher einen) Wie genau du das hinkriegst, weiß ich nicht genau.
    Auf meinem Suse ist es so: In der grafischen Oberfläche kannst du unter YaSt einstellen mit was du booten willst also entweder mit Lilo oder einem anderen. Wenn Linux einen anderen findet, zeigt er ihn dir an.
    Ich hoffe mal, dass ich das alles nicht zu ompliziert erklährt habe!
    Viel Glück!
    Gruß, Katja

  • Hallo Kes


    Erstmal Danke :D
    Ich hab mir deinen post audruckt und geh mal ins Linux schauen. Ich glaub das krieg ich schon hin!
    Melde mich bei Erfolgsmeldungen oder Fragen wieder


    MfG cYca

  • No problem! Ich drück dir die Daumen!
    Ansonsten hab ich hier noch ein dickes fettes Mandrake Buch!
    Gruß, Katja

  • boot=/dev/hda
    map=/boot/map
    install=/boot/boot.b
    vga=normal
    default=linux
    keytable=/boot/de-latin1-nodeadkeys.klt
    lba32
    prompt
    timeout=30
    message=/boot/message
    menu-scheme=wb:bw:wb:bw
    image=/boot/vmlinuz
    label=linux
    root=/dev/hda9
    initrd=/boot/initrd.img
    append=" hdb=ide-scsi"
    read-only
    image=/boot/vmlinuz
    label=failsafe
    root=/dev/hda9
    initrd=/boot/initrd.img
    append=" hdb=ide-scsi failsafe"
    read-only
    other=/dev/hda1
    label=windowsXP
    table=/dev/hda1
    other=/dev/hda6
    label=windows2000
    table=/dev/hda6
    other=/dev/hda5
    label=windows98
    table=/dev/hda5
    other=/dev/fd0
    label=floppy
    unsafe





    so müsste es doch funktionieren!! Tut's aber nicht!

  • der link ist einfach genial!!!


    Super Kes :D:D:D:D:D


    Es funktioniert aber immer noch nicht wirklich. Ich habe zwar jetzt im winXP Bootmanager Linux drinstehen, aber starten kann ich Linux nicht!
    Lilo ist auch immer noch beim Start zu sehen.
    Außerdem wollte ich noch sagen, dass ich vergessen habe zu erwähnen, dass ich win 2000 auch installiert habe. Aber das hat keine Auswirkung. Nur damit du dich im anderen post nicht wuderst!!


    Vielleicht könntest du mir einen Tipp geben, an was das liegen könnte.
    an der boot.ini von win xp glaub ich nicht!!
    also muss es an der lilo.conf oder ander bootsec.lin, oder nicht??



    danke im voraus kes


    MfG cYcaFleXx :lol:

  • äh guten morgen *erstmal kaffee trink*
    ja das mit 2000 hab ich auch gesehen, als ich heute nacht (ich konnte nicht schlafen *g*) den zettel mit dem ausdruck deiner lilo.conf durchforstet hab! Es sieht alles total ok aus, ich frage mich, warum der das nicht annimmt *gmpfl*
    ich bin ehrlich gesagt was ratlos.


    zum xp BM
    ich kann mir vorstellen, dass es doch an der boot.ini liegen muss wenn linux nicht startet, den ich schätze, das in der boot.ini noch nix über die genaue position von linux steht, oder?


    was das lilo angeht will ich dir keine voreiligen tips zum löschen geben.
    wie im ersten threat schonmal gesagt, kanst du lilo in der graphischen oberfläche (hat mandrake KDE?!!?) deaktivieren und den xp bm nehmen. das soll sehr einfach gehen und ich habe das anhand meines notebooks schon mal getestet.


    Puh ansonsten warte ich noch drauf, dass dir jemand in deinem anderen threat bescheid sagt, wie man den xp bm richtig konfiguriert. Wenn der nämlich läuft würde ich mich erst ans lilo deaktivieren machen, sonst hast du nachher einen bm der nix mehr startet *lach*


    ich lese mich heute mal ins mandrake buch ein, ich wette, da lässt sich was finden!


    Gruß, Katja

  • Also:


    Mit LILO kann ich win NT/2000/XP gar nicht starten.


    Soweit ich das verstanden habe, mache ich jetzt folgendes:


    Durch den Befehl: dd if=/dev/hda9 bs=512 count=1 of=/boot/bootsec.lin kopiere ich den Bootsektor von Linux in die Datei /boot/bootsec.lin !
    Anschließend nehme ich mir die /etc/lilo.cof vor .
    Diese ändere ich so, dass sie nicht den Bootsektor /dev/hda9 ändert, sondern die Datei /boot/bootsec.lin
    d.h. wenn ich das nächste mal lilo ausführe, ändert er die Datei /boot/bootsec.lin .


    dann sage ich in dem NTLDR (NT-Loader), dass es da noch ein Betriebssystem gibt, dass Linux heißt und wenn das jemand will, dann soll der NTLDR die Datei bootsec.lin aufrufen(die ich zuvor natürlich in die C-Platte kopiert habe)!


    Wie ich das im Detail mache, weiß ich so ungefähr, also wünsch mir viel Glück :lol:


    Ich hoffe ich habe es halbwegs erklährt!


    MfG cYca


    P.S.: Wenn ich heute keinen post mehr gib, dann nur, weil ich den LILO und den NTLDR auf dem gewissen habe! *jetzt noch lach, aber wenn passiert, nicht mehr so freu*

  • Hallo Kes


    Ich kann jetzt mit dem winXP Bootmanager Lilo starten. Juhu *freu*


    Aber bevor der winXP Bootmanager kommt, kommt Lilo!


    Weißt du wie man Lilo deaktiviert?


    MfG cYca

  • hi cyca!!


    Nach langer zeit meld ich mich wieder ;)


    Hmm deaktivieren von lilo ist ein heikles Thema. Von der Kommandozeile sicher schwierig!! Schau mal hier in der SuSe DB nach, die haben ja auch Mandrake Lösungen, Lilo ist ja meistens das slebe auf Madrake wie auch SuSe:


    http://sdb.suse.de/cgi-bin/sdb…ichwort=lilo+deaktivieren


    Ansonsten wie schon gesagt im Yast deaktivieren bzw Yast2.
    Mehr fällt mir da echt nicht ein!


    Gruß, Katja

  • ich hab gestern eine Idee gehabt:


    Ich deaktiviere Lilo nicht sondern stell die Lilo Version auf /dev/hda9(nicht die auf der C: Platte) auf 1 ms. Dann geht der PC zwar ins Lilo, aber ich sehs nicht, weils so schnell geht!! Wenn ich dann vom Windows Bootmanager aus in die Lilo-Version auf der C: Platte gehe sind noch die alten 3 sec. eingestellt und ich hab somit das erreicht, was ich wollte!



    Schau mal ob das hinhaut....




    MfG cYca

  • Hallo Kes


    Es funktioniert jetzt. Unsauber ist es schon; d.h. man sieht die Lilo am Anfang schon.
    Aber das reicht leicht für das was ich brauche!


    Danke,danke, danke Kes


    SUPER dass du mir geholfen hast!
    :D:D:D:D:D:D:D:D:D


    MfG cYca



    P.S.: Das Linux-Forum läuft wohl gut oder nicht?? Das war ne super Idee

  • :oops:
    Thx, aber ich danke dem, der das alles hier ermöglicht :) Also danke Schwabenpfeil *g*
    @cyca: Freue mich, dass es nun klappt, ich werde mir das merken *g* wenn ich irgendwann mal dazulerne, wie das deaktivieren nun genau geht oder es jemand anders weiß, wirds hier gepostet :)
    Gruß, Katja

Jetzt mitmachen!

Sie haben noch kein Benutzerkonto auf unserer Seite? Registrieren Sie sich kostenlos und nehmen Sie an unserer Community teil!