Problem mit Excel!

  • Hi!
    Ich habe vor in Excel eine Tabelle zu schreiben mit 2 Spalten, in der dann 2 Werte nebeneinander stehen, die zueinander gehören (wird wohl ca. 700 Zeilen lang). In einer anderen Tabelle möchte ich einen Wert aus der ersten Tabelle eingeben können und daneben soll dann der dazugehörige Wert aus der ersten Tabelle stehen. So müsste ich nicht jedesmal nach dem zugehörigen Wert suchen.
    Kann mir jemand dabei helfen? Ich nehm mal an, dass es am besten mit einem Makro geht. Ich bin aber auch für andere Lösungen offen.

  • hi
    also die erste Tabelle hat z.B.:
    in A1 --> 10
    und in
    B1 ---> 20


    Wenn du jetzt in Tabelle 2 in D1 ---> 10 einträgst soll
    in E1 automatisch 20 stehen ? so richtig ?
    Also: wenn D1 = A1 dann E1 = B1
    und so für alle Zellen


    Athlon XP 2800 + @ 2083 Barton
    WinFast 6600 GT TDH 128 MB
    WinXP SP 2
    FireFox 1.0.4 User

  • fast, in der 1. Tabelle steht z. B. irgendwo in A der Wert 20 und daneben in B der zugehörige Wert 3.
    Dann soll in der 2. Tabelle, wenn ich in A2 20 eingebe, der Wert in der 1. Tabelle in A gesucht werden und dann 3 in der 2. Tabelle in B2 stehen.

  • Ganz einfach!


    Angenommen die 1. Tabelle hat den Bereich A1:B700
    In der 2. Tabelle ist A die Eingabe-Spalte, in B soll der dem entsprechende Wert aus Tabelle 1 stehen.


    Dann lautet die Formel für Zeile 1/Spalte B Tabelle 2:


    =SVERWEIS(A1;Tabelle1!$A$1:$B$700;2)


    Übersetzt:
    Suche den Wert aus A1,
    in Tabelle 1, Bereich A1 bis B700,
    gib den zugehörigen Wert aus Spalte 2 aus.


    (Hinweis: Die Spalte 1 ist immer die, die im Bereich als erste angegeben ist, MUSS nicht A sein, auch wenn es Spalten M und N wären, ist M Spalte 1 und N Spalte 2 im Sinne der Formel!)


    So weit also schon gelöst!


    Allerdings gibt es, wenn kein passender Wert gefunden wird, ein #NV-Fehlerzeichen! Das kann man aber elegant unterdrücken mit:


    =WENN(ISTFEHLER(SVERWEIS(A1;Tabelle1!$A$1:$B$700;2));"nix";SVERWEIS(A1;Tabelle1!$A$1:$B$700;2))


    "nix", hier eine Textausgabe, kann beliebigen Text enthalten oder auch statt dessen natürlich "" (also leer) oder die Ziffer 0 sein; wie Du's brauchst!


    Rabe

    Computer setzen logisches Denken fort!
    Unlogisches auch....

  • Vielen Dank!
    Ich nehm mal an, dass ich es damit gut hinkrieg.

Jetzt mitmachen!

Sie haben noch kein Benutzerkonto auf unserer Seite? Registrieren Sie sich kostenlos und nehmen Sie an unserer Community teil!