Problem mit Booten

  • Hallo!
    Ich habe nach einem Neukauf Win XP Pro auf meiner SATA HD (250GB) installiert. Wegen gewissen besonderen Umständen konnte ich nicht SP2 installieren, was ich aber eigentlich brauche, um die Festplatte voll nutzen zu können. Nun habe ich XP Pro mit SP2 erhalten und wollte nun das istallierte OS updaten, was aber nicht geklappt hat, da eine Fehlermeldung kam, die besagte, dass eine Systemdatei nicht kopiert werden konnte, da die bestehende bereits von einem anderen Prozess verwendet wird. Virenprogramm habe ich deaktiviert. Nun gut, da ich nicht herausgefunden habe, welcher Prozess da stunk macht, habe ich das XP Pro SP2 per CD-Boot auf den unpartitionierten Teil der HD installiert. Nun kommt, wenn ich den PC aufstarte, die Aufforderung, das OS zu wählen, mit dem ich starten will, da nun auf 2 Partitionen 2 verschiedene Versionen des
    XPs installiert sind. Um diese Aufforderung zu umgehen, möchte ich einstellen, von welcher Partition gebootet wird, doch ich habe diese Einstellung im BIOS nirgends gefunden. Kann mir jemand sagen, wo ich das einstellen kann? Und weiss jemand, warum die "update-installation" nicht funktioniert hat?
    vielen Dank für die Antworten!

  • Steht auch nicht im Bios sondern in der boot.ini.


    Wenn Du die Möglichkeit hast poste hier mal den Inhalt - aber verändere an der Datei bitte nichts :!:
    Sonst bootet Dein Compu womöglich gar nicht mehr!


    Wenn Du nicht weißt wo die Datei ist und wie man sie zu Gesicht bekommt wirds umso schlimmer 8-)


    Bin zwar auch nicht so der Experte, aber hier gibts Leute die wissen was man an der Datei löschen muss.

  • Vielen Dank für die Antworten. Leider habe ich die boot.ini nicht gefunden (ja, ich weiss, dass es versteckte Dateien gibt :)). Kann mir jemand sagen, wo ich die finde?

  • Zwei Möglichkeiten zur Anzeige der Boot.ini
    1.
    Die Boot.ini findet man, wenn man im Windows-Explorer auf
    Erweitert >> Ordneroptionen >> Ansicht klickt, und das Häkchen bei
    "Geschützte Systemdateien ausblenden (empfohlen)" entfernt.
    Nun ist sie sichtbar und im Stamm(Root)verzeichnis zu finden.
    Meistens C:\
    2.
    Der einfachere Weg über die Systemsteuerung.
    Start >> Systemsteuerung >> System >> Erweitert >> Einstellungen
    (unter Starten und Wiederherstellen) >> Rubrik Systemstart
    Hier auf bearbeiten klicken und die Boot.ini wird geöffnet.

  • So, habs dank dem Tipp schnell gefunden:
    [boot loader]
    timeout=30
    default=multi(0)disk(0)rdisk(0)partition(2)\WINDOWS
    [operating systems]
    multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect
    multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /fastdetect
    Was muss ich nun verändern, damit es automatisch von einer Partition bootet?

  • Veränderte Boot.ini:


    [boot loader]
    timeout=30
    default=multi(0)disk(0)rdisk(0)partition(2)\WINDOWS
    [operating systems]
    multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect


    ____________________
    Also, Du löschst die letzte Zeile und speicherst die Boot.ini danach.


    Experimente würde ich aber nur machen, wenn das Betriebssytem auf "C" liegt. Das scheint aber nach meiner Boot.ini nicht zu sein.


    Dann warte bitte, bis sich noch jemand dazu äußert.


    Am Besten wäre eine neue Installation auf "C" mittels der Install-CD und dabei wird auch vorher formatiert.

  • Ich habe auf beiden Partitionen das OS Win XP Pro installiert, einmal SP1 und einmal SP2. Die Standardpartition soll C: sein, muss ich dann bei "default" Partition (2) auf 1 setzen?

  • Anton hat es doch schon beschrieben, lösch die unterste Zeile dann startet XP-SP2 das du auf deine 2te Partition installiert hast und es erscheint kein Auswahlmenü mehr beim starten.
    oder du löscht überhaupt nichts und änderst bei timeout die 30 auf 0


    Die Standardpartition soll C: sein, muss ich dann bei "default" Partition (2) auf 1 setzen?


    nein, dann würde wieder dein XP-SP1 starten .. wenn ich richtig verstanden hab willst du aber automatisch mit SP2 starten ohne Auswahlmenü , dann mach es so wie es oben beschrieben ist.
    ansonsten müßtest komplett neuinstalliern und zwar auf C: , so wie es sich gehört.

  • Nein, ich möchte automatisch SP1 (C:) starten, da auf dieser Partition alle Programme und Spiele installiert sind. Sorry fals ich mich ein wenig missverständlich ausgedrückt haben sollte.

  • Zitat von tomi1

    hm warum hast dann SP2 nachträglich auf eine 2te Partition installiert, naja egal
    dann trag bei default Partition (2) eine 1 ein und bei timeout eine 0


    vielen dank, ich werds gleich ausprobieren.

Jetzt mitmachen!

Sie haben noch kein Benutzerkonto auf unserer Seite? Registrieren Sie sich kostenlos und nehmen Sie an unserer Community teil!